Celso R.

Instalar Beryl

Posted in GNU/Linux, Software by Celso R. on 12 de Janeiro de 2007

Nota: O Beryl e o Compiz fundiram-se (o Beryl tinha sido uma “separação” do compiz) dando lugar ao Compiz fusion.

Podem seguir um de dois tutoriais:
http://wiki.compiz-fusion.org/Installation
Ou um referente à vossa distro:
http://wiki.compiz-fusion.org/Distributions

Este tutorial encontra-se desactualizado.

 

beryl

Este tutorial serve para todas as distros e ensina a instalá-lo através do svn.

Primeiro devem ver se têm aceleração 3d:

$glxinfo |grep direct
direct rendering: Yes

Depois activar AIGLX:

No file /etc/X11/xorg.conf acrescentar no fim:

Section “Extensions”
Option “Composite” “Enable”
EndSection

Na “Section module” certifique-se que tem a linha:

Load “dbe”

Para ati:

Certificar na Section “Device” que têm a seguinte linha:

“XAANoOffscreenPixmaps” “true”

Para nvidea:

Certificar na Section “Screen” que têm a seguinte linha:

Option “AddARGBGLXVisuals” “true”

e na Section “Device”:

Option “AllowGLXWithComposite” “true”

Beryl:

Começar por instalar o svn. Em Debian:

#apt-get install subversion

Depois instalar as dependências: cairo, cairo-devel, librsvg2-devel, libwnck-devel, GConf2-devel,startup-notification-devel ,intltool,gettext-devel, libxcomposite, libxdamage, python-pyrex

Podem instalá-las recorrendo ao apt-get.

Depois criar uma pasta na $home onde vamos guardar o que tiramos do svn.

(ex.)

$mkdir programas/beryl

Mudar para a pasta:

$cd programas/beryl

e correr o comando:

$svn co svn://svn.beryl-project.org/beryl

Para fazer download da última versão do beryl. Atenção que esta acção demora um pouco (consoante a ligação) e gasta bastante tráfego (+50mb).

Depois editem o ficheiro makeall:

$gedit programas/beryl/beryl/branches/beryl-0.1.4/makeall

(atenção que o beryl-0.1.4 varia consoante a última versão)

Em DEFCFLAGS= para:

DEFCFLAGS=”-O3 -march=pentium4 -ggdb3 -gstabs+ -Wall”

Óbvio que se não tiverem pentium 4 alteram para o vosso processador, podem ver a nomenclatura aqui: http://www.linuxjournal.com/article/7269 na parte “Table 2. x86 Architectures”.

Isto serve para optimizar o beryl para a arquitectura do vosso sistema.

Tirar o “aquamarine heliodor” de ITEMS= (pelo menos a mim dá problemas a compilar. Podem tentar. Senão vos der problemas. melhor.)

Gravar.

Entrar como root:

$su

escrever pass de root.

Depois:

#./makeall

Se não der nenhum erro, escrever na consola:

(escrever exit para sair do modo root)

$beryl-manager

Se quiserem que o beryl vos comece sempre que iniciam o GNOME é só adicionar beryl-manager em Preferências -> Sessões – Aplicações de arranque.

Resultado:

Free Image Hosting at www.ImageShack.us Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us Free Image Hosting at www.ImageShack.us
Free Image Hosting at www.ImageShack.us Free Image Hosting at www.ImageShack.us

Baseado em: http://wizah.blogspot.com/2006/10/debian-how-to-aiglx-compiz.html e http://www.techzonept.com/showthread.php?t=121539

19 Respostas

Subscribe to comments with RSS.

  1. CHARLES MUNIZ said, on 22 de Março de 2007 at 17:20

    Caro amigo Celso,

    Gostaria se possível que me desse uma luz.
    Quando digitei (como root) ./makeall, apareceu o seguinte erro:

    Na revisão 4514.
    ./autogen.sh: 9: autoreconf: not found
    BUILD FAILED for beryl-core

    Desde já agradeço.

    Att,

    Charles Muniz

  2. celsor said, on 22 de Março de 2007 at 19:42

    #apt-get install autoconf

    Neste site estão também o resto das dependências:
    http://wiki.beryl-project.org/wiki/Install_Beryl_on_Debian#Requirements_2

    BuildRequires: X11-devel >= 1.0.0
    BuildRequires: x11-util-macros >= 1.0.1
    BuildRequires: x11-proto-devel
    BuildRequires: libpng-devel
    BuildRequires: libwnck-devel
    BuildRequires: libgnome-window-settings-devel
    BuildRequires: gnome-desktop-devel
    BuildRequires: libxcomposite-devel
    BuildRequires: libxdamage-devel
    BuildRequires: intltool

  3. tales said, on 2 de Abril de 2007 at 22:18

    celso quando coloquei a primeira opçao nao apareceu nada oque faso ????????

  4. celsor said, on 2 de Abril de 2007 at 22:41

    Instala o mesa-utils

    #apt-get install mesa-utils

  5. tales said, on 2 de Abril de 2007 at 23:41

    obrigado

  6. Pedro said, on 26 de Abril de 2007 at 23:38

    Celso gostaria que me ajuda-se porfavor…

    quando digitei: ./makeall
    apareceu-me isto:
    Na revisão 4514.
    autoreconf: Entering directory `.’
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal –output=aclocal.m4t
    aclocal: configure.ac: 22: macro `AM_GLIB_GNU_GETTEXT’ not found in library
    autoreconf: aclocal failed with exit status: 1
    BUILD FAILED for beryl-core

    Obrigado desde já.

  7. celsor said, on 27 de Abril de 2007 at 10:05

    Veja se tem instalado o pacote Gettext:

    #aptitude install gettext gettext-base

  8. Pedro said, on 28 de Abril de 2007 at 23:33

    Obrigado , realmente eu não o tinha instalado.
    Mas eu não devo ir instalar o beryl bem porque depois de ter feito pesquisas, acho que o meu pc (pIII 783mgz 256mg) não da conta dos requisitos minimos.

    Celso, Continuação de uma bomtrabalho já demoinstrado.

  9. Markus said, on 29 de Abril de 2007 at 22:06

    Ola Celsor
    poderia me ajudar tambem ?
    obrigado

    root@notebook:/home/markus/programas/beryl/beryl/branches/beryl-0.2# ./makeall
    At revision 4514.
    Can’t exec “aclocal”: No such file or directory at /usr/bin/autoreconf line 182.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 182.
    Can’t exec “automake”: No such file or directory at /usr/bin/autoreconf line 183.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 183.
    autoreconf: Entering directory `.’
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal –output=aclocal.m4t
    Can’t exec “aclocal”: No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 290.
    autoreconf: failed to run aclocal: No such file or directory
    BUILD FAILED for beryl-core

  10. celsor said, on 1 de Maio de 2007 at 16:33

    Markus verifique se tem o automake instalado e o autoconf.

    #aptitude install automake
    #aptitude install autoconf

  11. Wesley said, on 29 de Maio de 2007 at 18:05

    Celso,
    tenho ubuntu 7.04 e windows XP (um em cada HD)

    [meu PC]
    atlhon 1.1
    256+512 DIMM
    HD’s 80+40
    DVD+RW

    posso usar o beryl sem placa de vídeo?
    detalhe, não tenho acesso a net em casa, posso baixar o beryl, gravar em CD e instalar em casa?
    aproveitando posso fazer o mesmo para ouvir mp3, baixar e gravar no cd e instalar em casa?

    obrigado.

  12. celsor said, on 29 de Maio de 2007 at 18:22

    Começando pelo mais simples, pode sacar os codecs mp3 aqui: http://packages.ubuntu.com/ grava num cd e depois é só clicar e instalar. O pacote para o ler mp3 é este: http://packages.ubuntu.com/feisty/libs/gstreamer0.10-fluendo-mp3

    ____

    Quando à placa de vídeo não precisa. Precisa é óbvio de uma placa gráfica (pressupondo que esteja a falar de coisas diferentes pois precisa sempre de uma placa gráfica para ver qualquer coisa no monitor ;) )

    Quanto ao Beryl pode sacar e usar, mas em vez de compilar o melhor é sacar e instalar os pacotes referentes ao Beryl: http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=beryl&searchon=names&subword=1&version=feisty&release=all

    Ou usar o Compiz que já vem com o Ubuntu 7.04

  13. Ricardo said, on 13 de Outubro de 2007 at 22:25

    Gostaria de receber mais comentários sobre a instalação do beryl

  14. celsor said, on 13 de Outubro de 2007 at 23:53

    O Beryl e o Compiz fundiram-se (o Beryl tinha sido uma “separação” do compiz) dando lugar ao Compiz fusion.

    Podem seguir dois tutoriais:
    http://wiki.compiz-fusion.org/Installation
    Ou um referente à vossa distro:
    http://wiki.compiz-fusion.org/Distributions

  15. Anderson Araujo said, on 15 de Março de 2008 at 20:02

    olá celso Instalei o Ubuntu no meu micro :

    Cpu:Athlon 3800 2.0Ghz
    1Gb DDR2
    Placa mãe da PC Chips modelo A33G
    placa de vídeo on-board Com conpartilhamento de memória

    Gostaria de saber se com essa config posso instalar o beryl.
    Se não qual o melhor upgrade para suportar o beryl…
    obrigado

  16. celsor said, on 9 de Abril de 2008 at 21:26

    Dado que é uma placa onboard duvido que consiga correr como dever ser. só sabendo o modelo da placa e se esta tem pelo menos aceleração 3D em Linux.

  17. Anderson Araujo said, on 14 de Abril de 2008 at 5:05

    Celso
    a placa de video é Sis 140 tem aceleraçao 3D mas não consigo ativar a aceleração no linux no
    windows funciona bem roda até need for speed pro street
    tem algum jeito de instalar driver de outra placa ative a aceleração do video no window isso funcionou uma vez instalei o driver de uma via e funcionou

  18. Pablo said, on 13 de Fevereiro de 2009 at 14:08

    Celso
    quando eu tento edita o xorg da o seguinte erro…

    Unable to remove old X config backup file ‘/etc/X11/xorg.conf.backup’.

    oq pode ser ?

  19. celsor said, on 14 de Fevereiro de 2009 at 11:22

    Não está a editar como root?


Os comentários estão fechados.

%d bloggers like this: